MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000349Downloadspublic2011-12-23 11:372012-11-09 09:06
Reportergeosone 
Assigned ToMijzelf 
PrioritynoneSeverityfeatureReproducibilityN/A
StatusassignedResolutionreopened 
Platformarmv5OSSabLinkOS Version0
Summary0000349: Request for ftp access for a new Distribution called Sablink
DescriptionSablink is like Genlink
it is gentoo based distro but with prepacked packages
to have a proper support for binary packages a the package system from sabayon was taken
so the name SabLink

version 0 is for the alpha release (still not a real distro just a migration path from genlink)

my privat server on the corpate network i am working for is not motivated to support the downloads

this a request to get access to download.nas-central.org (or have a subdomain sablink.nas-central.org
Additional Informationthere is a devel sablink repository
http://sablink.disconnected-by-peer.at/standard/ [^]

the devel wiki for now
http://sablink.disconnected-by-peer.at [^]
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000591)
Mijzelf (administrator)
2012-03-16 18:25

Hi, I have enabled ftp access on your bugtracker account. Can you test if it works at ftp://downloads.nas-central.org? [^]

Sorry for the delay.

The download site is at the moment at gpl.nas-central.com/.Sablink. Will have to consult others to find out a better place.
(0000593)
geosone (developer)
2012-03-16 19:23

great thx.
no problem university is cracy lately
(0000595)
geosone (developer)
2012-03-17 05:43

Upload working
will take some weeks befor really the dist is landing there
(compiling takes ages)
(0000597)
Mijzelf (administrator)
2012-03-17 10:31

Great. Issue closed.
(0000611)
geosone (developer)
2012-10-19 14:14

So i am in th prozess on creating the packaes for upload
any thougths on creating a new subdomain like packages.nas-cental.org or playground.n-c.org or distribution.n-c.org ....

thx
Mario
(0000613)
geosone (developer)
2012-10-19 14:16

because gpl.n-c.org is not the right name for a distribution
(0000619)
geosone (developer)
2012-11-04 22:23

is something with the ftp its not working ?
(0000621)
Mijzelf (administrator)
2012-11-05 07:06

Works for me. What is the problem? Server down, or login rejected?
(0000623)
geosone (developer)
2012-11-05 07:10

timeout it looks like i have been rejected by a firefall
(0000625)
timtim (administrator)
2012-11-05 10:39

Hi,
We can setup subdomain but I need to submit a change request for this and it will be setup quickly.

something.sablink.nas-central.org is preferred my end, to keep things separate if that is OK. Sorry for the delay in response - let me know what you need!
(0000627)
geosone (developer)
2012-11-05 11:00

this is ok with me

pkgs.sablink.nas-central.org for the start so i can start uploading the packages
(will be something like that http://pkgs.sabayon.org/ [^]) i will also start looking for mirrors that want to support this project

for now i would create a wiki package in the buffalo wiki that describes the install in the ls gl/xhl/chl2 (i have these to test) but mayby later
www.sablink.n-c.org (a wiki)
and even alter
packages.sablink.n-c.org where the sablink package wenent will be intalled
something like https://packages.sabayon.org/ [^]

but this is faar faar away for now lets start pkgs.sablink.nas-central.org
(0000629)
timtim (administrator)
2012-11-05 12:16

Thanks, I will pop in the change request now for the DNS. It should hopefully be acted upon when the US wakes up.
(0000631)
geosone (developer)
2012-11-05 12:19

will there be some new ftp account or even better ssh account
(0000633)
timtim (administrator)
2012-11-05 12:20

Yep, we can do an FTP account
(0000635)
timtim (administrator)
2012-11-05 12:23

An alternative is that we could connect to your server via ssh and rsync changes over periodically (cron) to the right place.
(0000637)
geosone (developer)
2012-11-05 12:25

no pkgs.sl.n-c.org will be the main location i am already talking with mirror.inode.at the mayby will create an european mirror
(0000639)
geosone (developer)
2012-11-05 13:30

because the packaging software directly updates the the servers and mirrors.
(0000641)
timtim (administrator)
2012-11-05 15:54

Apparently the DNS has been changed, and this will take a short while to propagate.
(0000643)
timtim (administrator)
2012-11-06 22:53

Do you want to upload with your 'geosone' bug tracker account or a separate one?

A little area and subdomain exists for this now, I just need to hook it up to some account so you can fill it up!

http://pkgs.sablink.nas-central.org [^]
(0000645)
geosone (developer)
2012-11-06 23:47

a seperate one would make sense it would not me allone who uses this upload
and using my account he could be me
(0000647)
geosone (developer)
2012-11-07 05:15

and having for every sablink dev another accoutn also makes no sense
because the development box (pandaboard) working with chroot's can only be don by root.
so the sablink devs get root access to do mount umount emerge ...
and the account name is standing cleartext in the entropy server config. so a general sablink account with a nice alphanumeric password would be the best
(0000649)
timtim (administrator)
2012-11-07 08:34

OK, can you register an account here on the bug tracker (the accounts on mantis are used for the ftp when the permissions are set correctly) and let me know the name of it please, then I can put it into the right group for access.
(0000651)
geosone (developer)
2012-11-07 08:40

the account name is sablink
and thx for supporting this project
(0000653)
timtim (administrator)
2012-11-07 08:46

No problem! Please test out the upload to ftp.nas-central.org using this account - the files should appear at http://pkgs.sablink.nas-central.org [^] now. Let us know if it does not work!
(0000655)
geosone (developer)
2012-11-07 08:49

timeout on connect i think my ip is blocked
(0000657)
timtim (administrator)
2012-11-07 08:54

Yes it was in the drop list (too many authentication failures result in a temporary block) - please try now.
(0000659)
geosone (developer)
2012-11-07 08:56

still landing on http://www.nas-central.org/wiki/Main_Page [^] when accessing pkgs.sablink.nas-central.org
(0000661)
timtim (administrator)
2012-11-07 08:57

This might be your browser cache, I can see LFSR.c that you have uploaded in the web interface!
(0000663)
geosone (developer)
2012-11-07 09:00

you are right browser cache whats the name of the file thet is expected to get the 404 warnings away ?
(0000665)
timtim (administrator)
2012-11-07 09:08

That should be resolved now - there are header and footer files you can see in the root of your upload directory that provide our logos and some links (I know the disclaimer is missing!).
(0000667)
geosone (developer)
2012-11-07 18:29

thx is there also an anonymous ftp access to this ?
(0000669)
timtim (administrator)
2012-11-09 09:06

Unfortunately we don't have a way to do this with the current setup really.

- Issue History
Date Modified Username Field Change
2011-12-23 11:37 geosone New Issue
2012-03-16 18:25 Mijzelf Note Added: 0000591
2012-03-16 19:23 geosone Note Added: 0000593
2012-03-17 05:43 geosone Note Added: 0000595
2012-03-17 10:31 Mijzelf Note Added: 0000597
2012-03-17 10:31 Mijzelf Status new => closed
2012-03-17 10:31 Mijzelf Assigned To => Mijzelf
2012-03-17 10:31 Mijzelf Resolution open => fixed
2012-10-19 14:14 geosone Note Added: 0000611
2012-10-19 14:14 geosone Status closed => feedback
2012-10-19 14:14 geosone Resolution fixed => reopened
2012-10-19 14:16 geosone Note Added: 0000613
2012-10-19 14:16 geosone Status feedback => assigned
2012-11-04 22:23 geosone Note Added: 0000619
2012-11-05 07:06 Mijzelf Note Added: 0000621
2012-11-05 07:10 geosone Note Added: 0000623
2012-11-05 10:39 timtim Note Added: 0000625
2012-11-05 11:00 geosone Note Added: 0000627
2012-11-05 12:16 timtim Note Added: 0000629
2012-11-05 12:19 geosone Note Added: 0000631
2012-11-05 12:20 timtim Note Added: 0000633
2012-11-05 12:23 timtim Note Added: 0000635
2012-11-05 12:25 geosone Note Added: 0000637
2012-11-05 13:30 geosone Note Added: 0000639
2012-11-05 15:54 timtim Note Added: 0000641
2012-11-06 22:53 timtim Note Added: 0000643
2012-11-06 23:47 geosone Note Added: 0000645
2012-11-07 05:15 geosone Note Added: 0000647
2012-11-07 08:34 timtim Note Added: 0000649
2012-11-07 08:40 geosone Note Added: 0000651
2012-11-07 08:46 timtim Note Added: 0000653
2012-11-07 08:49 geosone Note Added: 0000655
2012-11-07 08:54 timtim Note Added: 0000657
2012-11-07 08:56 geosone Note Added: 0000659
2012-11-07 08:57 timtim Note Added: 0000661
2012-11-07 09:00 geosone Note Added: 0000663
2012-11-07 09:08 timtim Note Added: 0000665
2012-11-07 18:29 geosone Note Added: 0000667
2012-11-09 09:06 timtim Note Added: 0000669


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker